VPN vb. çalıştırıyorsanız dış IP’niz değiştiğinde haberdar olmak isteyeceksinizdir. Üç ihtimaliniz var.

  • Statik IP alacaksınız
  • Dinamik DNS kullanacaksınız
  • Bu yazının konusu olan Mikrotik scriptini kullanacaksınız.

Email kurulumu

Daha önce Mikrotik’ten e-mail göndermediyseniz cihaza e-posta server’ınız ve erişim bilgilerinizi tanımlamanız gerekli.

Winbox: Tools>Email

SSH/Console:

/tool e-mail
set address=emailserver.com
set port=587
set from=me@emailserver.com
set user=myuser
set password=mypassword

Bilgileri sunucunuza uygun şekilde değiştirmeyi unutmazsınız sanırım.

 

Script

Bu kodla global bir değişken yaratıp script her çağrıldığında bu değişken ile seçtiğimiz interface’ın şu anki IP değerini karşılaştırıyor, farklılık görürsek e-posta gönderimi tetikliyoruz.

Takip edilecek interface adı (wired interface takip ediyorsanız ether1 vb., ya da benim örneğimde pppoe-out1) ve email adresiniz şeklinde belirtilen yerleri uygun şekilde değiştirin.

SSH/Console:

/system script add name="ipChangeDetect" source={
  :global currIP;

  :local newIP [/ip address get [find interface="TAKIP EDILECEK INTERFACE ADI"] address];

  :if ($newIP != $currIP) do={
    :set currIP $newIP;
    /tool e-mail send to="EMAIL ADRESINIZ" \
     subject="IP adresiniz degisti!"\
     body=$currIP;
  }
}

Winbox: System>Scripts altında ekleme yapabilirsiniz.

 

 

Zamanlama

Scriptin düzenli aralıklar ile tetiklenmesi gerekli. 1 dakika makul bir süre.

SSH/Console:

/system scheduler add name=ipchange-mail interval=1m on-event=ipChangeDetect

Winbox: System>Scheduler

Görüldüğü gibi gayet basit. Kolay gelsin.